Ghostscript quickfix alternative 1 for Ubuntu 11.10

Upgrade ghostscript to the version currently found in the Ubuntu 12.04 Precise Pangolin repository.

Add the Precise repository, but only use ghostscript from it. Will track ghostscript development and also any new bugs. This solution might break if the packages suddenly starts depending on something from Precise, e.g. a new libc version. This fix must be removed from your system before doing a release upgrade!

See Ubuntu fixes for more information.

The fix:

# Add to /etc/apt/sources.list:
--------------------------------------------------------------------------------
# Next Ubuntu release
# This entry is used for getting a newer version of ghostscript.
# Must be used together with:
# /etc/apt/preferences.d/ghostscript-from-precise
# !!! Remove this entry and the file mentioned !!!
# !!! above before doing a release upgrade!    !!!
deb http://archive.ubuntu.com/ubuntu/ precise main universe
deb http://archive.ubuntu.com/ubuntu/ precise-updates main universe
deb http://archive.ubuntu.com/ubuntu/ precise-security main universe
--------------------------------------------------------------------------------

# Create /etc/apt/preferences.d/ghostscript-from-precise:
--------------------------------------------------------------------------------
Package: *
Pin: release n=precise
Pin-Priority: -10

Package: ghostscript ghostscript-dbg ghostscript-doc ghostscript-cups ghostscript-x libgs-dev libgs9 libgs9-common gs-gpl gs-common
Pin: release n=precise
Pin-Priority: 500
--------------------------------------------------------------------------------

# Run these commands:
sudo chown root.root /etc/apt/preferences.d/ghostscript-from-precise
sudo chmod 644 /etc/apt/preferences.d/ghostscript-from-precise
sudo apt-get update
sudo apt-get dist-upgrade

# Remember: Remove the fix again before doing a release upgrade!

[Main page] [Ubuntu fixes]

Valid HTML 4.01 Transitional