Ghostscript quickfix alternative 2 for Ubuntu 11.10

Upgrade ghostscript to the version currently found in the Ubuntu 12.04 Precise Pangolin repository.

Manually download and install deb packages from the Precise repository. No automatic updates (which may provide security fixes)!

See Ubuntu fixes for more information.

The fix:

# Find your architecture:
dpkg --print-architecture

# Find which ghostscript packages you have installed on your system:
dpkg -l | grep 9.04

# Download the packages you need (i386 architecture):
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/ghostscript_9.04~dfsg-2ubuntu3_i386.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/ghostscript-dbg_9.04~dfsg-2ubuntu3_i386.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/ghostscript-cups_9.04~dfsg-2ubuntu3_i386.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/ghostscript-doc_9.04~dfsg-2ubuntu3_all.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/ghostscript-x_9.04~dfsg-2ubuntu3_i386.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/libgs-dev_9.04~dfsg-2ubuntu3_i386.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/libgs9_9.04~dfsg-2ubuntu3_i386.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/libgs9-common_9.04~dfsg-2ubuntu3_all.deb

# Download the packages you need (amd64 architecture):
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/ghostscript_9.04~dfsg-2ubuntu3_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/ghostscript-dbg_9.04~dfsg-2ubuntu3_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/ghostscript-cups_9.04~dfsg-2ubuntu3_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/ghostscript-doc_9.04~dfsg-2ubuntu3_all.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/ghostscript-x_9.04~dfsg-2ubuntu3_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/libgs-dev_9.04~dfsg-2ubuntu3_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/libgs9_9.04~dfsg-2ubuntu3_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/libgs9-common_9.04~dfsg-2ubuntu3_all.deb

# If the links above don't work, try to find the latest version of the packages at:
# <http://archive.ubuntu.com/ubuntu/pool/main/g/ghostscript/>
# Or just update the URLs above with the latest version number, which can be found here:
# <https://launchpad.net/ubuntu/precise/+source/ghostscript>

# Install the packages:
sudo dpkg --install *.deb

# Note: You will not get automatic security updates for these packages!
# Watch for updates here:
# <https://launchpad.net/ubuntu/precise/+source/ghostscript>

[Main page] [Ubuntu fixes]

Valid HTML 4.01 Transitional